PAT1027_C/C++_编程开发_程序员俱乐部

中国优秀的程序员网站程序员频道CXYCLUB技术地图
热搜:
更多>>
 
您所在的位置: 程序员俱乐部 > 编程开发 > C/C++ > PAT1027

PAT1027

 2016/8/4 5:32:51  iamH  程序员俱乐部  我要评论(0)
  • 摘要:PeopleinMarsrepresentthecolorsintheircomputersinasimilarwayastheEarthpeople.Thatis,acolorisrepresentedbya6-digitnumber,wherethefirst2digitsareforRed,themiddle2digitsforGreen,andthelast2digitsforBlue.Theonlydifferenceisthattheyuseradix13(0-9andA-C
  • 标签:


People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input

Each input file contains one test case which occupies a line containing the three decimal color values.

Output

For each test case you should output the Mars RGB value in the following format: first output "#", then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a "0" to the left.
Sample Input

15 43 71

Sample Output

#123456

#include<iostream>
#include<stack>
using namespace std;
void f(int in);
int main(){
    int in1,in2,in3,temp;
    char s[13]={'0','1','2','3','4','5','6','7','8','9','A','B','C'};
     cin>>in1>>in2>>in3;
     stack<char>  st;
     cout<<"#";
     f(in1);
     f(in2);
     f(in3);
    return 0;
}

void f(int in){
     stack<char>  st;
     bool b=false;
     char s[13]={'0','1','2','3','4','5','6','7','8','9','A','B','C'};
     int temp;
     if(in<13){
            b=true;
     }

    do{
        temp=in%13;
        st.push(s[temp]);
        in=in/13;
     } while(in!=0);

     while(!st.empty()){
        if(b==true){
            cout<<"0"<<st.top();
        }
        else{
            cout<<st.top();
        }
        st.pop();
     }
}

上一篇: PAT1015 下一篇: 一个项目经理的贪嗔痴
  • 相关文章
发表评论
用户名: 匿名