PAT1008_C/C++_编程开发_程序员俱乐部

中国优秀的程序员网站程序员频道CXYCLUB技术地图
热搜:
更多>>
 
您所在的位置: 程序员俱乐部 > 编程开发 > C/C++ > PAT1008

PAT1008

 2016/8/4 5:32:51  iamH  程序员俱乐部  我要评论(0)
  • 摘要:1008.ElevatorThehighestbuildinginourcityhasonlyoneelevator.ArequestlistismadeupwithNpositivenumbers.Thenumbersdenoteatwhichfloorstheelevatorwillstop,inspecifiedorder.Itcosts6secondstomovetheelevatoruponefloor,and4secondstomovedownonefloor
  • 标签:
1008. Elevator

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

Output Specification:

For each test case, print the total time on a single line.
Sample Input:

3 2 3 1

Sample Output:

4



#include<iostream>
#include<queue>
using namespace std;

int main(){

   // int a[10]={3,2,3,1};
   int n;
     queue<int> tempQ;
   cin >> n;
   for(int i=0;i<n;i++){
        int t;
        cin>>t;
        tempQ.push(t);
   }


//   for(int i=0;i<=3;i++){
//       tempQ.push(a[i]);
//   }
    int flow = 0;
    int size = tempQ.size();
    int now,d, sum=0;
    while(!tempQ.empty()){
            int nextFlow = tempQ.front();

            if(flow > nextFlow){
                 d = flow -nextFlow;
                 sum = sum + 4 * d+5;

            }else{
                 d = nextFlow - flow;
                  sum = sum + 6 * d+5;
            }
            flow = nextFlow;
            tempQ.pop();

    }
    cout<<sum<<endl;

    return 0;
}
上一篇: PAT1005 下一篇: PAT1015
  • 相关文章
发表评论
用户名: 匿名