PAT1005_C/C++_编程开发_程序员俱乐部

中国优秀的程序员网站程序员频道CXYCLUB技术地图
热搜:
更多>>
 
您所在的位置: 程序员俱乐部 > 编程开发 > C/C++ > PAT1005

PAT1005

 2016/8/4 5:32:50  iamH  程序员俱乐部  我要评论(0)
  • 摘要:1005.SpellItRightGivenanon-negativeintegerN,yourtaskistocomputethesumofallthedigitsofN,andoutputeverydigitofthesuminEnglish.InputSpecification:Eachinputfilecontainsonetestcase.EachcaseoccupiesonelinewhichcontainsanN(<=10100).OutputSpecification
  • 标签:
1005. Spell It Right

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:

Each input file contains one test case. Each case occupies one line which contains an N (<= 10100).

Output Specification:

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.
Sample Input:

12345

Sample Output:

one five



#include<iostream>
#include<string>
#include<stack>
#include<string.h>
using namespace std;

int main(){
    char input[100];
    cin>>input;
    string str[10]={"zero","one","two","three","four","five","six","seven","eight","nine"};
    int len,sum=0;
    len = strlen(input);
    for (int i=0; i<len ; i++){
        sum += input[i] - '0';
    }
    stack<string> st;
    int temp;
    do{
            temp = sum % 10;
            st.push(str[temp]);
            sum = sum/10;

    }while(sum!=0);
    cout<<st.top();
    st.pop();
    while(!st.empty()){
        cout<<" "<<st.top();
        st.pop();
    }
    cout<<endl;
    return 0;

}


  • 相关文章
发表评论
用户名: 匿名