第五届在线编程大赛月赛第一题:完全平方数的个数_JAVA_编程开发_程序员俱乐部

中国优秀的程序员网站程序员频道CXYCLUB技术地图
热搜:
更多>>
 
您所在的位置: 程序员俱乐部 > 编程开发 > JAVA > 第五届在线编程大赛月赛第一题:完全平方数的个数

第五届在线编程大赛月赛第一题:完全平方数的个数

 2014/6/13 0:20:21  vcdemon  程序员俱乐部  我要评论(0)
  • 摘要:题目详情:给定整数区间[A,B]问其中有多少个完全平方数。输入格式:多组数据,包含两个正整数A,B1<=A<=B<=2000000000。输出格式:每组数据输出一行包含一个整数,表示闭区间[A,B]中包含的完全平方数的个数。答题说明:输入样例111231033输出样例:1120importjava.util.Scanner;publicclassTestTwo{publicstaticintTest(intm,intn){intcount=m;if(m>n){m=n
  • 标签:编程 在线

class="her_caption" style="">题目详情:

给定整数区间[A,B]问其中有多少个完全平方数。

输入格式:

多组数据,包含两个正整数A,B 1<=A<=B<=2000000000。

输出格式:

每组数据输出一行包含一个整数,表示闭区间[A,B]中包含的完全平方数的个数。

?

答题说明:

输入样例

1 1

1 2

3 10

3 3

输出样例:

1

1

2

0

?

?

import java.util.Scanner;

public class TestTwo {
    public static int Test(int m,int n) {
        int count=m;
        if (m>n) {
            m=n;
            n=count;
        }
        count=0;
        
        for (int i = m; i <= n; i++) {
            int sum=0;
            for (int j = 1; j <= i;) {
                sum=sum+2*j-1;
                if (sum==i) {
                    count++;
                    break;
                }
                if (j>=(i/2+1)) {
                    break;
                }
               j=j+1; 
            }
        }
        return count;
    }
    
    public static void main(String[] args) {
        Scanner sc=new Scanner(System.in);
        while (true) {
            int m=sc.nextInt();
            int n=sc.nextInt();
            System.out.println(Test(m, n));
        }
    }
}

?

发表评论
用户名: 匿名